Issues with Indian Passport renewal via VFS Global

i am having problem while making payment. Its not letting me go further after creating application on VFS website.

anyone else faced same issue? how did you resolve it? i tried contacting VFS global Cutomer care via email as number is not mentioned on their website. I did not receive any reply till now.

Hello Sonal_Dhamija,

I had the same issue, when i’m trying to add New customer it would do nothing, does not take me to next page or anything… I found below advise on Am22tech site , however, it did not work for me. let me know if it does for you.

Go to # Step5a from this link

#Step 5a Many people have complained that they are not able to see the ‘select courier service’ after adding a customer.

Try this as it worked for us:

  1. Log out and Log in again to VFS Global portal.
  2. Click the ‘retrieve incomplete application‘ button (blue color) given on the left-hand side menu.
  3. Use your registered email (used to register on the VFS site) and click search.
  4. You should now be able to see the ‘Select courier‘ option on the customer list screen as shown in our next step below.
  5. If you are still not able to see the ‘select courier service‘ option, then click the ‘Edit‘ link given in the ‘Actions‘ column next to your name list. This should show the courier service option.

I’m having the same problem. I contacted support yesterday and below is the response -

“Thank you for high lighting this issue and the same has already been resolved, you may now try to add new customer, fill out the form and proceed further.”

But, no luck yet!! The support team is taking 24hrs to answer follow-up questions on the same thread :slight_smile:
I did multiple attempts to contact consulate (phone, email). no response!! I made a trip to consulate (SFO) too… that is a different story (horrible experience).

Yes i saw this yesterday and tried doing the same way. but no luck. I tried contacting VFS via email as there is no contact number, no reply from them.

this is so weird and frustrating at the same time.

good luck!

Looks like CKGS is resuming services from 11/9. Total chaos…

@sureshrk19 @Sonal_Dhamija , Was this issue resolved? I am getting the same issue and its been 2 days now. No response from VFS so far.

Please Help! I am trying to renew my mom’s passport on this all glitched out VFS Global website but it won’t let me add new customer. When I fill out all the details and click on submit it brings me back to same screen.

It seems VFS is the only option again. The pop-up was not there now on ckgs website.

@sureshrk19 @Sonal_Dhamija - Any luck on submitting the application?
I followed the steps in updated post - logout and login and search for application. When I search by giving my application I am getting records not found message. I tried this on Nov 5th itself, then also it didn’t work.
If any of you able to make it success, please post here.

@Lakshmi_Pabbisetti, No luck!!! Tried multiple times…
No response from consulate or VFS support either.

I am not able create my application on VFs website. website is not accepting my application.

just checked again, having the same issue since 2 days

What the worst service is this? I am not able to submit an application for the past 3 days. My Kid passport expired last month and not able to get this done. We have some urgent travel coming up in 2 weeks. Not sure what to do.

I’m stuck at add customer screen with no error. Log out, login, retrieve app does not help. How do I contact VFS? I tweeted their 24x7 global care and no one cares. What is the point of 24x7 then?

Not working for me either the add customer screen. Workaround mentioned here doesn’t work either. Anybody else got it working?

Tries multiple times in different browser. Not working for me as well on Add new Customer step. What a mismanagement? Opened a support case, waiting to hear.

Stuck at add customer screen as well, tried different email, browsers, operating systems. Has anyone submitted the form successfully?

I am having same issue, not able to add customer. I looked page in developers tools, looks like its technical issue, Passport field is rendered at Govt reference field and vise versa.
I sent email to embassy and VFS but no response. This is really frustrating. Not sure why VFS is not fixing issue. Looks like VFS is not at ready to provide services just delaying it.
Tried in Chrome, firefox, IE but no luck