Unable to download vfs courier label

I got a confirmation email from vfs global. I have taken the vfs courier service but I am unable to download it, showing the following message:

  • “There is no record available for the details shared. Please verify if you are entering the correct details associated with your login ID”

I have also tried different browsers, but same message is showing.

Any help will be appreciated.


Try using incognito/private mode on browsers until this weekend. In the past, we have seen Systems undergoing maintenance during weekend. You can still go ahead and reach out to VFS for resolution.

Also, remember to turn off any VPN, in case you are using one.

Thanks. I have tried all possible ways but nothing is working. Its only showing no record found.

I have the same issue today. I got the confirmation email but get the same error message that you posted above when tried to download courier label. Seems like there is maintenance over weekend because I had issues accessing this website last weekend too. Hopefully, it will work on Monday but meanwhile if the issue is resolved for you, please keep me updated. thanks.

Yes definitely I will inform. If you get a solution to the issue, please post the resolution. Thanks.

Same issue for me as well :frowning: please confirm here if its started working for anyone.

Same here, completed the application and paid for VFS courier service yesterday, seeing the “no record found” error since then. Sent a message to help desk, but no response. Will update here if I get any help or see progress.

same issue for me as well , just finished my application by paying and now seeing the “no record found” error

Anyone got this issue resolved? I have sent an email and waiting for their response.

I am encountering the same issue. I have already made a request to support team and sent a DM to vfs customer care twitter handle. No response.

Hi… But I am still getting the same error? Is the issue resolved for all?

Nope, not for me yet.

I am also in the same boat. Calling VFS is also an issue as the first 5 mins are free and they they will start charging for the mistake they had done

there is no response from VFS even after being on hold on the call for more than 35 mins.

1 Like

wow so they charged you like anything… are they saying anything like will they send manually or what?

Actually no one answered and call disconnected automatically. they said charge will be applied only after the live agent is connected. I am still waiting for the courier labels.

I found this but still no luck https://services.vfsglobal.com/one-pager/india/united-states-of-america/oci-services/pdf/Courier%20Label%20for%20Incomplete%20App.pdf

1 Like

Hi, I am also getting this error. Tried incognito, doesn’t work for me either. What happens for you when you try to “Email Confirmation Letter”? It shows the same error.
Waiting for some news on this thread. I will update if I see any change.

you can get the incomplete application and then get the confirmation letter from there but still not the fedex label. its stupid that they ask for money upfront and there is no way to contact them without paying and say if we decide to go with our label then it is a waste of money which you will never get back

I just paid and got confirmation letter
Same issue that I’m not able to download courier labels

Post if anyone have solution

Thanks much