Unable to login to passport seva website

I received my new passport on last Friday. From yesterday I am not able to login to government passport seva website. It throws error incorrect password even after I have reset my password using forgot password. How to check further status if police verification is initiated for me

3 Likes

same here. the site “https://portal3.passportindia.gov.in/” is behaving erratically and not allowing to login despite entering correct credentials and its has been the case for more that 2 days now. I have twitted by tagging @passportSeva Support, sent emails but neither see any replies to emails nor to tweets. I curious if anyone in authorities is even noticing this?
helpless and frustrated
:frowning:

Yup. Faced the same problem. Tried multiple browsers as well, no luck :frowning:

Guys I got reply from consulate for my pramit query. They said- ‘the passport seva portal is facing technical issue. The website is maintained in india and the issue is looked into’

1 Like

I am also facing this issue since last 2 days.

I too am facing the same issue since past 3 days. Does anyone have luck? I changed my password multiple times and it always says Authentication failed when I attempt to login.

I am having the same issue. has it worked for anyone else yet?

following for same issue
https://portal3.passportindia.gov.in/

It’s not resolved yet, I sent an email to the consulate office. Lets see if they get it fixed soon.

I am able to login without any issue now

I am not able to login and getting Authentication failed message. After 3 retry it locked the account and asked for password reset.

I can login now. It seems that they fixed the issue.

My account got locked. So I reset the password using forgot password and tried again now. Still facing the same issue. Does it work for anyone whose account got locked?

I cant login as well. Its always say that Authentication Failed even after resetting password. Is it working for anyone else ?
I need to apply for my passport renewal and have been trying since more than a week now.

I am facing this problem again. It seems that they didn’t fix the problem.

I am able to login now . somehow it worked.

Dear all… I am facing the same glitch.Unable to login despite using correct login credentials.Tried changing passwords several times, tried at different times, used different devices and web browsers, it’s still of no use.The web portal auto fills some random lengthy password overriding the password I entered resulting in unsuccessful login attempts.No response from the embassy either.Has anyone resolved this issue ? Pls help!

Still unable to login. I reset my password 3 times in the last 3 days. Reset it again 30 mins ago and tried logging in. Still shows the login error - “Authentication failed. Please enter correct password.”

The issue was first seen on Saturday May, 06, 2022. It’s disappointing to see it is not yet resolved after 3 business days. The portal admins are not kind enough send an email to portal users that the website is experiencing technical issues or at-least place a message on the website. Just terrible!

I too had same issue, but I found a work-around to move further and able to re-login in to my a/c.
This issue exists as long as you are trying to reset the password using E-mail option. Instead of E-mail try with ‘security hint question’, if you answer your hint question correctly (worst part is, you need to match the exact case for this question, which you have provided before) then it will reset your password instantly and you will be able to login instantly. Hope it helps for few people.

Krishna Theja…I have no issues in resetting the password either way - using email option or hint question option.My issue is everytime I try to log in with my username and password…the website automatically autofills some lengthy password and attempts to log me in…resulting in unsucessful log in attempts and account getting locked.Though I am able to unlock my account by resetting the password it wont let me log into my account to start my process …it keeps saying authentication failed.