VFS Passport Renewal - Unable to download shipping label

I’ve recently applied online for passport renewal fin the VFS website & in spite of submitting the application online & making a payment on Nov 8, I’ve not been able to download shipping labels to ship the package. Please help in this urgent matter

1 Like

Hi Rushabh @Rushabh_Warhadkar ,

Were you able to download the Shipping label? I am also in same situation.

I have been asked by VFS to get my own label but they did not provide any address information.
Are you from Texas?

-Neeraj

Hi @Neeraj_Vasudeva - I’m applying from SFO. I was able to download the labels are 3-4 days.

Thanks a lot for the prompt response, appreciate it @Rushabh_Warhadkar

So you did not had to do anything extra to make it work?
Did you tried everyday for 3-4 days or u just happen to try only on the 3rd day?
I am wondering if the problem would automatically disappear if i try tomorrow.

-Neeraj

@Neeraj_Vasudeva - Submit the form on VFS website Contact Us link. They usually get back in a couple of days. Keep trying for 3-4 days. Pathetic service.

Ok, thanks for the update, appreciate it.

-Neeraj

@Rushabh_Warhadkar
Don’t know if it’s just a coincidence, i just thought may be there is some sort of a batch job that runs on their end which may allow me to download the Courier as soon as it become 12 am… rightfully so, I just tried it at 12:01 CT and voila it worked :slight_smile:

I woud be sending them the documents along with the passport tomorrow, and hopefully i finally get my renewed passport back soon.

@Rushabh_Warhadkar Did you already got your passport back and did you apply in normal processing?

-Neeraj

I am on the same situation. Its been more than 2 days and dont see any courier label . Very frustrating. Any suggestions here

Hi Rushabh, I am facing the same issue. Can anyone please help on this?

In the email you get from vfs for application confirmation there is a link to download labels. You have to login to the website and there will be a download courier labels link on left hand side. Do you see it?

VFS will not send it as an attachment, you have to go and manually download.

If you get errors when you download, you will have to contact VFS unfortunately. Based on experiences here you will have to generate your own personal shipping labels.

1 Like

Hi @Poulina_Daniel - I would recommend reaching out to VFS via the Google form on their website and also call them to notify about this issue. For me, once I filled the form out, I waited for a 3-4 days and I was able to download the labels. They notified me when I should go in and download them. It’ll work but unfortunately will require 3-4 days.

I tried from Mozilla and it worked. I recommend doing from Mozilla

1 Like

Hi

Any validity for downloaded FedEx prepaid shipping label?. FedEx shipping label- date printed on it! how long is it valid for?

I have similar issue. Failed to download courier label,Please try again later.

Not sure, what should I do.

Thank you so much after reading your message I was able to print out the label

I had similar issue yesterday. I have tried on all the browsers. IE, Chrome, Microsoft Edge, Firefox. But nothing worked. Then I login to VFS site on my Samsung Note 8. I used Chrome on phone. I could down load and print the courier label from there. You can also give a try and let everyone know, whether it worked for you.

Thank you, I have able to down load the courier label after few hours.

I’m running into the same issue. However, on top of that, I’m also unable to find my application as well. After the payment was complete, it just logged me out instead of taking to download the courier labels. Now when I log back in to download the labels and try finding my application, it is saying “no records found”. I’ll try after a few hours, as everyone suggested above.

@Sujit_Mandal @Rushabh_Warhadkar : Was it showing no records found for you too or were you able to find the application and just the downloading wasn’t working? I didn’t get a reference number either.

I had the same issue but worked when I tried using Safari browser on my Apple laptop.

1 Like

Same issue from last two days… I tried with edge today, worked for me…